
Z8 Encore! XP® F042A 8-Pin 
Development Kit

Quick Start Guide QS005505-0508
Introduction
This Quick Start Guide describes how to set up Zilog’s Z8 Encore! XP® 8-Pin 
Development Kit and start using it to build designs and applications.

Kit Contents
Hardware
Hardware requirements include:
• Z8 Encore! XP F042A Series 8-Pin Development Board, Z8F04A08100KITG
• USB Smart Cable for connecting the PC to Z8 Encore! XP F042A Series Development 

Board
• 5 V DC Universal Power Supply

Software (on CD-ROM)
Software requirements include:
• Zilog Developer Studio II (ZDS II)—Z8 Encore!® Integrated Development 

Environment (IDE)
• Full ANSI C-Compiler included
• Sample Code
• Acrobat Reader 
• Document Browser

Documentation
The Z8 Encore! XP Technical Documentation (on CD-ROM) include:

– Development Kit User Manual 
– ZDS II–IDE User Manual (UM0130)
– eZ8 CPU User Manual (UM0128)
– Product Specification
– Product Brief
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– Product Line Card

Requirements
Table 1 lists the system requirements for running ZDS II.

Configuring the 5 V DC Universal Power Supply
The universal power supply kit features several different plug adapters in one box and the 
power supply itself in another. The power supply ships with a slide-out plate that must be 
removed to insert the location-specific plug adapter.
1. Remove the slide-out plate.
2. Select the AC plug adapter appropriate for your locale and insert it into the slot that 

remains after removing the slide-out plate.
3. Slide the new plug adapter into the slot until it snaps into place.
You can leave the adapter slot cover in place and plug in a standard computer equipment 
AC power cord (purchased separately) between the AC cord receptacle on the end of the 
power supply and an electrical outlet.

Table 1. ZDS II System Requirements

Recommended Configuration Minimum Configuration
• PC running MS Windows XP 

Professional, SP1
• Pentium III/500 MHz or higher processor
• 128 MB RAM
• 110 MB hard disk space
• Super VGA video adapter
• CD-ROM drive
• Ethernet port
• One or more RS-232 communications 

ports
• USB High-Speed Port

• PC running MS Windows 98SE/
Win2000–SP3/WinXP Professional–SP1

• Pentium II/233 MHz processor
• 96 MB RAM
• 25 MB hard disk space (documentation 

not installed)
• Super VGA video adapter
• CD-ROM drive
• Ethernet port
• One or more RS-232 communications 

ports
• USB High-Speed Port
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Setting Up the Development Board
The USB Smart Cable connects the target Z8 Encore! XP development board to a high-
speed or full-speed USB port on your ZDS II host system.

Always use a grounding strap to prevent damage resulting from electro-
static discharge (ESD).

Figure 1 displays a simplified development board.

Figure 1. Z8 Encore! XP 8-Pin Development Board

Follow the steps below to setup the development board:

1. For initial setup, ensure that jumper J2, DIS IRDA, is IN (shunt installed). For detailed 
jumper descriptions, refer to Z8 Encore! XP® F042A Series 8-Pin Development Kit 
User Manual (UM0187).

2. Your development kit can run either in Standalone Demo mode or in DEBUG mode. 
Standalone Demo mode runs the preloaded code for demonstration purposes and is a 
simple way to verify that the board is working properly.

Caution:

DBG Connector
Pin 1 (indicated 
by square)
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To run the kit in Standalone Demo mode, ensure that the jumpers are set as follows: 
• J3 1-2
• J4 OUT
• J5 1-2
• J6 1-2
• J7 OUT
• J8 1-2
• J9 1-2
• J10 1-2
• J11 OUT

To run the kit in DEBUG mode, follow the steps as described in Getting Started Using 
ZDS II on page 8. For complete details on jumper settings for Z8 Encore! XP MCU 
8-pin development kits, refer to Z8F04A08100KITG Z8 Encore! XP® F042A 8-Pin 
Series User Manual (UM0187).

3. Install the included USB Smart Cable as described below for the appropriate operating 
system.

Do not connect the power supply to the development board before con-
necting a USB Smart Cable to both the host PC and development board.

Windows XP

Follow the steps below to install USB Smart Cable for Windows XP:

1. Connect the Zilog USB device to the Host PC. The Found New Hardware Wizard 
should activate automatically after connecting the Zilog USB device for the first time; 
select No, not at this time if asked to connect to Windows Update.

2. Select Install from a list or specific location (Advanced); then click Next.

If the Windows Logo testing dialog appears, select Continue Anyway.

3. Select Search for the best driver in these locations and Include this location in 
search:. 

4. Browse to the following driver directory and click Next.
           <ZDS installation>\device drivers\USB

5. Click Next after the appropriate driver is found.

Caution:

Note:
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6. Click Finish to complete the installation.

Windows 2000

Follow the steps below to install USB Smart Cable for Windows 2000:

1. Connect the Zilog USB device to the Host PC. The Found New Hardware Wizard 
should activate automatically after connecting the Zilog USB device for the first time.

2. Click Next in the Found New Hardware Wizard after it has been activated.

3. Select Search for a suitable driver for my device (Recommended) and click Next.

4. Select Specify a location and click Next.

5. Browse to the following driver directory and click OK.
           <ZDS installation>\device drivers\USB

6. Click Next after the appropriate driver is found.
7. Click Finish to complete the installation.

Windows 98SE

Follow the steps below to install USB Smart Cable for Windows 98SE:

1. Connect the Zilog USB device to the Host PC. The Add New Hardware Wizard 
should activate automatically after connecting the Zilog USB device for the first time.

2. Click Next in the Add New Hardware Wizard after it has been activated.

3. Select Search for the best driver for your device (Recommended) and click Next.

4. Select Specify a location: and browse to the following driver directory, and click 
Next.

           <ZDS installation>\device drivers\USB

5. Click Next after the appropriate driver is found.
6. Click Finish to complete the installation.

Connecting the USB Smart Cable to the Target Board
Attach one end of the six-conductor ribbon cable (included) to the USB Smart Cable six-
pin DBG connector, as displayed in Figure 2. Attach the free end of the ribbon cable to the 
DBG connector on the target board. Ensure that pin 1 on the ribbon cable (indicated by the 
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dark stripe) is aligned with pin 1 on the target connector (see Figure 1 on page 3 for loca-
tion of pin 1 on the Z8 Encore! XP® 8-pin development board).

Figure 2. Connecting the Six-Conductor Ribbon Cable to the USB Smart Cable

Applying Power to the Development Board

Follow the steps below to apply power to the development board:

1. After installing the USB Smart Cable, connect the power supply to the development 
board at connector P1, then to an electrical outlet.

2. Slide Power switch S2 to the ON position.

The Green 3.3 V DC LED illuminates, indicating that power is being supplied to the 
board. LEDs D2, D3, and D4 should blink in sequence, indicating that your board is 
running the preloaded demonstration software. This means your board is functional 
and ready for prototyping.
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Installing the ZDSII–Z8 Encore!® Software
Follow the steps below to install the software tools:
1. Load the ZDS II CD into the CD-ROM drive of the host PC. The CD launches 

DemoShield automatically and provides a menu to install the product and 
documentation. 

2. Select INSTALL PRODUCTS, and then INSTALL ZDS II to display the Installa-
tion Wizard.

3. Click Next to continue with the installation. The License Agreement appears. Read it 
carefully as it represents your agreement for legal use of Zilog® software.

4. Select Yes to accept the agreement and proceed with the installation.
5. After selecting Yes, the Choose Destination Location screen appears. Follow the 

directions on the screen and choose whether to install ZDS II in the default location or 
in some other folder. Click Next.

Unless you select a different location, the software is installed in:
C:\Program Files\ZiLOG\ZDSII_Z8Encore_<version_number>\

where <version_number> is the ZDS II version number (for example, 4.9.4).
6. The Select Program folder screen appears. Follow the directions on the screen and 

click Next. Unless you select a different location, the program is located in the Start 
menu under 
Programs → ZiLOG ZDSII Z8 Encore! <version_number> → ZDSII Z8 
Encore! <version_number>

7. After selecting Next, the Register Your Software screen appears, reminding you to 
register the development kit online. To register, visit http://support.zilog.com/support/ 
and enter your Zilog® Support user name and password, or select Create Account if 
you do not have one. After logging in, select Register New Products.

Registered users can submit technical questions online and check status of their 
questions by logging in and clicking the Support Requests menu. They also receive 
free ZDS II updates, notification of new ZDS II versions, and can download other 
related free software online.

8. Select Next to continue. The Installation Wizard Complete page appears. You can now 
view the README file and/or launch ZDS II before finishing the installation.
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Getting Started Using ZDS II
Follow the steps below to open and use the ledBlink.zdsproj sample project.

These procedures reference the ledBlink.zdsproj file located in
c:\Program Files\ZiLOG\ZDSII_Z8Encore_<version_number>\
Samples\Z8xxxx_ledBlink\src, where <version_number> is the ZDS 
II version number and Z8xxxx is the CPU family. For example:

For ZDS II v4.10.1 or lower:
c:\Program Files\ZiLOG\ZDSII_Z8Encore_4.10.1\Samples\
Z8F04XP_ledBlink\src.

For ZDS II v4.11.0 and later:
c:\Program Files\ZiLOG\ZDSII_Z8Encore_4.11.0\Samples\
XP_F082A\XP_F042A_LedBlink\src.

1. To run the sample project with the ZDS II debugger enabled, set the jumpers on the 
development board as follows:

• J1 OUT
• J2 IN
• J3 OUT
• J4 IN (must be installed to run in DEBUG mode)
• J5 1-2
• J6 1-2
• J7 IN (must be installed to run in DEBUG mode)
• J8 1-2
• J9 1-2
• J10 1-2
• J11 OUT

2. Connect and apply power to the development board as described in Setting Up the 
Development Board on page 3.

Do not apply power to the development board unless the USB Smart 
Cable is connected both to the host PC and to the development board’s 
DBG port P3.

Note:

Caution:
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3. Run the ZDS II software. By default, the ZDS II program is located in the Start menu 
under:
Programs → ZiLOG ZDSII Z8 Encore! <version_number> → ZDSII Z8
Encore! <version_number>

4. Select Open Project from the File menu. The Open Project dialog box appears.

The sample used in the following steps is in the C programming language. An 
assembler version of the ledBlink sample is located in the 
Z8F04XP_8Pin_ledBlink_asm\src folder.

5. Browse to the Samples folder for the ledBlink.zdsproj file, located by default in:
c:\Program Files\ZiLOG\ZDSII_Z8Encore_<version_number>\Samples\
Z8F04XP_8Pin_ledBlink\src

6. Select the ledblink.zdsproj file and click Open. The initial ZDS II program 
screen appears (see Figure 3 on page 10).

If you want to view the project source files, double-click the Project Files folder on 
left side of the IDE interface. Double-click an individual file to open that file in the 
ZDS II file editor.

The following figures are for reference only. You may have a newer version of 
the software.

Note:

Note:
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Figure 3. ZDS II Opening Screen

7. Select the correct debug tool using Project → Settings → Debugger → Debug Tool. 
For example, select USBSmartCable when using the USB Smart Cable. Click F1 for 
additional information on how to setup the debugger.

8. Click OK.
9. Click the Rebuild All icon to build the project. Wait for the build to complete as 

indicated by the ‘Build Complete’ confirmation in the status window at the bottom of 
the screen.

10. Click the Reset icon to connect and download the code to the development 
board.
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11. Click Go icon to start the program. The screen changes as displayed in Figure 4.

Figure 4. ZDS II Active Screen

12. Two LEDs on the development board begin blinking in sequence. If the LEDs do not 
blink, repeat Step 3 on page 9.

LED D2/PA0 is shared with the DBG pin. Zilog® does not recommend having 
the LED connected while connecting to the target or while in debug mode (J3 
should be OUT).

13. Press the TEST push button to change the sequence of the LEDs to blink in the 
opposite direction.

Note:
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For more information about using ZDS II and building projects for your Z8 Encore! XP 
development kit, refer to Zilog Developer Studio II–Z8 Encore!® User Manual (UM0130).

You can also use the Z8 Encore! XP F042A series 8-pin development kit and 
its sample project to evaluate the development environment for the Z8 Encore! 
XP F08xA and F0823 Series 8-pin MCUs. The Z8 Encore! XP F042A series 8-
pin development kit board may also be used with a ZDS project that targets 
the Z8 Encore! XP F08xA or F0823 8-pin devices. However, the device feature 
limitations, such as reduced program space, will exist. The Z8 Encore! XP 
F042A 8-pin device on the development board may also be replaced with a Z8 
Encore! XP F08xA or F0823 8-pin device for a more detailed chip evaluation.

Troubleshooting Tips
If you experience trouble running the demo program with the Z8 Encore! XP development 
board, check the following before contacting Zilog Technical Support for assistance:
• Verify that you are using ZDS II version 4.9.2 or later. 
• Ensure that you are using the unmodified sample project code as described in Getting 

Started Using ZDS II on page 8. 
• Verify that you have properly connected the USB Smart Cable to the host PC and the 

8-pin development board as described in Setting Up the Development Board on page 3. 
Ensure that pin 1 of the cable is properly aligned with DBG connector pin 1 of the 
development board.

• Apply power to the development board using S2 slide switch. The green 3.3 V DC 
LED should be ON. If it is not illuminated, verify if power is properly connected to the 
board as described in Configuring the 5 V DC Universal Power Supply on page 2.

• In ZDS II, verify select the Project → Settings → Debugger → Communication 
menu item and verify that the serial number for the USB Smart Cable interface is present 
and selected. If the serial number is missing, reinstall the USB Smart Cable driver 
software.

• In ZDS II, verify that Z8F04A08100KITG-USB is selected as the target.
• In ZDS II, click the Rebuild All  button. Verify that the project rebuilds with no 

errors.
• Verify that the development board is not currently running any code—no LEDs should 

be blinking.
• In ZDS II, click the IDE Reset  button. ZDS II will connect to the development 

board and download code to it.

Note:
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• Open the Windows Hyperterminal application (located in your Accessories program 
group) and connect a DB9-to-DB9 cable between your host PC and console port P2 of 
the development board. Set the communication settings to 57600 8 bits, no parity, one 
stop bit. This is noted on main.c file.

• Click the Go  button. The Red and Yellow LEDs should blink in sequence. The 
hyperterminal should display the ‘Led Lights...’ message.

If the demo code still does not run, contact Zilog® Technical Support at www.zilog.com.
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DO NOT USE IN LIFE SUPPORT

LIFE SUPPORT POLICY
ZILOG'S PRODUCTS ARE NOT AUTHORIZED FOR USE AS CRITICAL
COMPONENTS IN LIFE SUPPORT DEVICES OR SYSTEMS WITHOUT THE
EXPRESS PRIOR WRITTEN APPROVAL OF THE PRESIDENT AND GENERAL
COUNSEL OF ZILOG CORPORATION. 

As used herein
Life support devices or systems are devices which (a) are intended for surgical implant
into the body, or (b) support or sustain life and whose failure to perform when properly
used in accordance with instructions for use provided in the labeling can be reasonably
expected to result in a significant injury to the user. A critical component is any
component in a life support device or system whose failure to perform can be reasonably
expected to cause the failure of the life support device or system or to affect its safety or
effectiveness.

Document Disclaimer
©2008 by Zilog, Inc. All rights reserved. Information in this publication concerning the
devices, applications, or technology described is intended to suggest possible uses and
may be superseded. ZILOG, INC. DOES NOT ASSUME LIABILITY FOR OR
PROVIDE A REPRESENTATION OF ACCURACY OF THE INFORMATION,
DEVICES, OR TECHNOLOGY DESCRIBED IN THIS DOCUMENT. ZILOG ALSO
D O E S  N O T  A S S U M E LI A B I L I T Y  F O R  I N T E L L EC T U A L  PR O P E RT Y
INFRINGEMENT RELATED IN ANY MANNER TO USE OF INFORMATION,
DEVICES, OR TECHNOLOGY DESCRIBED HEREIN OR OTHERWISE. The
information contained within this document has been verified according to the general
principles of electrical and mechanical engineering.

Z8, Z8 Encore!, and Z8 Encore! XP are registered trademarks of Zilog, Inc. All other
product or service names are the property of their respective owners.

Warning:
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