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PICkit™ 2 USER’S GUIDE

Preface
INTRODUCTION 

This chapter contains general information about this user’s guide and customer support 
that will be useful prior to using the PICkit™ 2 Microcontroller Programmer. Items 
discussed in this chapter include:

• Document Layout
• Conventions Used in this Guide
• Warranty Registration
• Recommended Reading
• The Microchip Web Site
• Development Systems Customer Change Notification Service
• Customer Support
• Document Revision History
• Troubleshooting

DOCUMENT LAYOUT 

This document describes how to use the PICkit™ 2 Microcontroller Programmer. The 
manual layout is as follows:

• Chapter 1. PICkit™ 2 Overview – An overview of the PICkit™ 2 Microcontroller 
Programmer.

• Chapter 2. Getting Started – Provides instruction on how to get started using the 
PICkit™ 2 Microcontroller Programmer to program Flash-based PICmicro® 
microcontroller units (MCU).

• Chapter 3: PICkit™ 2 and ICSP™ – Provides instruction on programming with 
the PICkit™ 2 Microcontroller Programmer using In-Circuit Serial Programming™ 
(ICSP™).

• Chapter 4: Updating the PICkit™ 2 Operating System – Provides instruction on 
how to update your PICkit™ 2 Microcontroller Programmer’s Operating System.

NOTICE TO CUSTOMERS

All documentation becomes dated, and this manual is no exception. Microchip tools and 
documentation are constantly evolving to meet customer needs, so some actual dialogs 
and/or tool descriptions may differ from those in this document. Please refer to our web site 
(www.microchip.com) to obtain the latest documentation available.

Documents are identified with a “DS” number. This number is located on the bottom of each 
page, in front of the page number. The numbering convention for the DS number is 
“DSXXXXXA”, where “XXXXX” is the document number and “A” is the revision level of the 
document.

For the most up-to-date information on development tools, see the MPLAB® IDE on-line help. 
Select the Help menu, and then Topics to open a list of available on-line help files.
© 2005 Microchip Technology Inc. DS51553A-page 1
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• Chapter 5: Troubleshooting – Provides resolutions for frequently asked 
questions that solve common problems when using the PICkit™ 2 Microcontroller 
Programmer.

• Appendix A: Hardware Schematics – Illustrates the PICkit™ 2 Microcontroller 
Programmer hardware schematic diagrams. 

CONVENTIONS USED IN THIS GUIDE

This manual uses the following documentation conventions

DOCUMENTATION CONVENTIONS 

WARRANTY REGISTRATION

Please complete the enclosed Warranty Registration Card and mail it promptly. 
Sending in the Warranty Registration Card entitles users to receive new product 
updates. Interim software releases are available at the Microchip web site.

Description Represents Examples

Code (Courier font):

Plain characters Sample code
Filenames and paths

#define START
c:\autoexec.bat

Angle brackets: < > Variables <label>, <exp>

Square brackets [ ] Optional arguments MPASMWIN [main.asm]

Curly brackets and pipe 
character: { | }

Choice of mutually exclusive argu-
ments; An OR selection

errorlevel {0|1}

Lowercase characters in 
quotes

Type of data "filename"

Ellipses... Used to imply (but not show) addi-
tional text that is not relevant to the 
example

list 
["list_option..., 
"list_option"]

0xnnn A hexadecimal number where n is a 
hexadecimal digit

0xFFFF, 0x007A

Italic characters A variable argument; it can be either a 
type of data (in lowercase characters) 
or a specific example (in uppercase 
characters).

char isascii (char, 
ch);

Interface (Arial font):

Underlined, italic text 
with right arrow

A menu selection from the menu bar File > Save

Bold characters A window or dialog button to click OK, Cancel

Characters in angle 
brackets < >

A key on the keyboard <Tab>, <Ctrl-C>

Documents (Arial font):

Italic characters Referenced books MPLAB® 
IDE User’s Guide
DS51553A-page 2 © 2005 Microchip Technology Inc.
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RECOMMENDED READING

It is recommended that you become familiar with the documents listed below, prior to 
using the PICkit™ 2 Microcontroller Programmer.

PICkit 2 Low Pin Count Demo Board User’s Guide (DSXXXXX)

Consult this document for instructions on how to use Microchip Technology’s Low Pin 
Count devices (8-pin, 14-pin and 20-pin). This document includes a series of tutorials.

MPLAB® IDE, Simulator, Editor User’s Guide (DS51025)

Consult this document for more information pertaining to the installation and features 
of the MPLAB Integrated Development Environment (IDE) Software.

THE MICROCHIP WEB SITE

Microchip provides online support via our web site at www.microchip.com. This web 
site is used as a means to make files and information easily available to customers. 
Accessible by using your favorite Internet browser, the web site contains the following 
information:

• Product Support – Data sheets and errata, application notes and sample 
programs, design resources, user’s guides and hardware support documents, 
latest software releases and archived software

• General Technical Support – Frequently Asked Questions (FAQs), technical 
support requests, online discussion groups, Microchip consultant program 
member listing

• Business of Microchip – Product selector and ordering guides, latest Microchip 
press releases, listing of seminars and events, listings of Microchip sales offices, 
distributors and factory representatives

DEVELOPMENT SYSTEMS CUSTOMER CHANGE NOTIFICATION SERVICE

Microchip’s customer notification service helps keep customers current on Microchip 
products. Subscribers will receive e-mail notification whenever there are changes, 
updates, revisions or errata related to a specified product family or development tool of 
interest.

To register, access the Microchip web site at www.microchip.com, click on Customer 
Change Notification and follow the registration instructions.

The Development Systems product group categories are:

• Compilers – The latest information on Microchip C compilers and other language 
tools. These include the MPLAB C18 and MPLAB C30 C compilers; MPASM™ 
and MPLAB ASM30 assemblers; MPLINK™ and MPLAB LINK30 object linkers; 
and MPLIB™ and MPLAB LIB30 object librarians.

• Emulators – The latest information on Microchip in-circuit emulators.This 
includes the MPLAB ICE 2000 and MPLAB ICE 4000.

• In-Circuit Debuggers – The latest information on the Microchip in-circuit 
debugger, MPLAB ICD 2.

• MPLAB® IDE – The latest information on Microchip MPLAB IDE, the Windows® 
Integrated Development Environment for development systems tools. This list is 
focused on the MPLAB IDE, MPLAB SIM simulator, MPLAB IDE Project Manager 
and general editing and debugging features.

• Programmers – The latest information on Microchip programmers. These include 
the MPLAB PM3 and PRO MATE® II device programmers and the PICSTART® 
Plus and PICkit® 1development programmers.
© 2005 Microchip Technology Inc. DS51553A-page 3
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CUSTOMER SUPPORT

Users of Microchip products can receive assistance through several channels:

• Distributor or Representative
• Local Sales Office
• Field Application Engineer (FAE)
• Technical Support
• Development Systems Information Line

Customers should contact their distributor, representative or field application engineer 
(FAE) for support. Local sales offices are also available to help customers. A listing of 
sales offices and locations is included in the back of this document.

Technical support is available through the web site at: http://support.microchip.com

In addition, there is a Development Systems Information Line which lists the latest ver-
sions of Microchip’s development systems software products. This line also provides 
information on how customers can receive currently available upgrade kits.

The Development Systems Information Line numbers are: 

1-800-755-2345 – United States and most of Canada

1-480-792-7302 – Other International Locations

DOCUMENT REVISION HISTORY

Revision A (May 2005)

• Initial Release of this Document.

TROUBLESHOOTING

• See Chapter 5 for information on common problems.
DS51553A-page 4 © 2005 Microchip Technology Inc.



PICkitTM 2 USER’S GUIDE
Chapter 1.  PICkit™ 2 Overview
1.1 INTRODUCTION

This chapter introduces the PICkit™ 2 Microcontroller Programmer and describes the 
PICkit™ 2 Microcontroller Programmer features and menu functions.

1.2 HIGHLIGHTS

This chapter discusses:

• The PICkit™ 2 Contents
• The PICkit™ 2 Overview
• PICkit™ 2 Programming Software

1.3 PICkit™ 2 MICROCONTROLLER PROGRAMMER CONTENTS

The PICkit™ 2 Microcontroller Programmer Kit contains the following items:

1. The PICkit™ 2 Microcontroller Programmer
2. USB cable
3. PICkit™ 2 Starter Kit CD ROM

1.4 INTRODUCING THE PICkit™ 2 MICROCONTROLLER PROGRAMMER

The PICkit™ 2 Microcontroller Programmer is a low cost development programmer. It 
is capable of programming most of Microchip’s Flash microcontrollers. For specific 
products supported, see the README file included on the PICkit™ 2 Starter Kit CD 
ROM.

The PICkit™ 2 Microcontroller Programmer Operating System (firmware) can be easily 
upgraded from the programming software. New device support can be added by 
updating the operating system. The latest firmware is available on Microchip’s web site, 
www.microchip.com.

Note: The PICkit™ 2 Microcontroller Programmer is intended for development 
programming. For production programming, please consider the MPLAB 
PM3 Programmer or other third party programmers designed for the 
production environment.
© 2005 Microchip Technology Inc. DS51553A-page 5
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1.5 PICkit™ 2 MICROCONTROLLER PROGRAMMER OVERVIEW

The PICkit™ 2 Microcontroller Programmer overview is shown in Figure 1-1.

FIGURE 1-1: PICkit™ 2 MICROCONTROLLER PROGRAMMER

1.5.1 USB Port Connection

The USB Port Connection is a USB mini-B connector. Connect the PICkit™ 2 
Microcontroller Programmer to the PC using the supplied USB cable.

1.5.2 Status LEDs

The Status LEDs indicate the status of the PICkit™ 2 Microcontroller Programmer.

1. Power (green) – Power is applied to the PICkit™ 2 Microcontroller Programmer 
via the USB port.

2. Target (yellow) – The PICkit™ 2 Microcontroller Programmer is powering the 
target device.

3. Busy (red) – The PICkit™ 2 Microcontroller Programmer is busy with a function 
such as Program mode or is alerting that a function is in progress.

1.5.3 Push Button

The push button is for initiating a function and presently not implemented.

1

2

4

3

56

Legend:

1 – Status LEDs 3 – Lanyard Connection 5 – Pin 1 Marker

2 – Push Button 4 – USB Port Connection 6 – Programming Connector
DS51553A-page 6 © 2005 Microchip Technology Inc.
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1.5.4 Programming Connector

The programming connector is a 6-pin connector (0.100" spacing) to connect to the 
target device. See Figure 1-2 for the pinout specification. Pin 1 is indicated by the 
triangle.

For more information on how to use the PICkit™ 2 Microcontroller Programmer with 
In-Circuit Serial Programming™ (ICSP™), refer to Chapter 3. “PICkit™ 2 and 
ICSP™”.

FIGURE 1-2: PICkit™ 2 CONNECTOR PINOUT

1.5.5 Lanyard Connection

The lanyard connection is a convenient place to attach a lanyard or line to keep the 
PICkit™ 2 Microcontroller Programmer from becoming lost.

Pin Descriptions

1 – VPP/MCLR

2 – VDD Target

3 – VSS (Ground)

4 – ICSPDAT/PGD

5 – ICSPCLK/PGC

6 – Auxiliary

1
2
3
4
5
6

Note: The connector is a 6-pin header with 0.100" spacing and can accept 
0.025" square pins.
© 2005 Microchip Technology Inc. DS51553A-page 7
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1.6 PROGRAMMING SOFTWARE

Start the PICkit™ 2 Programming Software by selecting Start > Programs > PICkit 2 
Microcontroller Programmer > PICkit 2. The programming interface appears as shown 
in Figure 1-3.

For more information on how to use the PICkit™ 2 Programming Software, see 
Chapter 2. “Getting Started”.

FIGURE 1-3: PICkit™ 2 Programming Software

Menu Bar

Status Bar
Progress Bar

Program Memory

Device Configuration

Data EEPROM Memory
DS51553A-page 8 © 2005 Microchip Technology Inc.
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1.6.1 Menu Bar

The menu bar selects various functions of the PICkit™ 2 Programming Software. 
A summary of the functions are:

FILE

Import File – Import a hex file for programming
Export File – Export a hex file read from a device
Exit – Exit the program (duplicated with the Quit button)

DEVICE FAMILY

Baseline (12-bit Core) – Configures the programming software for baseline Flash 
devices
Mid-range (14-bit Core) – Configure the programming software for mid-range 
Flash devices
PIC18 – Configures the programming software for PIC18F Flash devices (future 
feature, presently grayed out)
PIC18J – Configures the programming software for PIC18FXXJXX Flash devices 
(future feature, presently grayed out)
dsPIC – Configures the programming software for dsPIC Flash devices (future 
feature, presently grayed out)

PROGRAMMER

Read Device – Reads program memory, data EEPROM memory, ID locations, 
and configuration bits.
Write Device – Writes program memory, data EEPROM memory, ID locations, and 
configuration bits.
Verify – Verifies program memory, data EEPROM memory, ID locations and 
configuration bits read from the target MCU against the code stored in the 
programming software.
Erase – Performs a bulk erase of the target MCU. OSCCAL and band gap values 
are preserved (PIC12F629/675 and PIC16F630/676 only).
Blank Check – Performs a blank check of program memory, data EEPROM 
memory, ID locations and configuration bits.
Full Erase (OSCCAL and BG erased) – Performs a bulk erase including the 
OSCCAL and Band Gap (BG) values (PIC12F629/675 and PIC16F630/676 only).
Regenerate OSCCAL – Regenerates the OSCCAL value (only for 
PIC12F629/675 and PIC16F630/676). The AUX line must be connected to the 
RA4/T1G pin.
Set Band Gap Calibration Value – Sets the band gap value (only for 
PIC12F629/675 and PIC16F630/676).

TOOLS

Code-Protect Device – Enables code protection features of the microcontroller on 
future write operations.
Target Power – Power target from PICkit™ 2 Microcontroller Programmer.
Check Board – Verifies communication with the PICkit™ 2 Microcontroller 
Programmer and reads the device ID of the target MCU.
Download PICkit 2 Operating System – Performs a download of the PICkit™ 2 
Microcontroller Programmer firmware operating system.

ABOUT

This displays a dialog box indicating the version and date.
© 2005 Microchip Technology Inc. DS51553A-page 9
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1.6.2 Device Configuration

The Device Configuration window displays the PICmicro MCU device, User ID, 
Configuration Word and Checksum. It also displays OSCCAL and Band Gap, which are 
available only on PIC12F629/675 and PIC16F630/676 devices.

For mid-range (14-bit core) devices, the PICkit™ 2 Microcontroller Programmer reads 
the device ID and displays it in the window.

For baseline (12-bit core) devices, the user must select the device from a drop down 
box.

1.6.3 Status Bar

The status bar displays text status of the operations in progress. If an operation is 
successful, the status bar will display green background. If an operation fails, the status 
bar will display red. If an operation alerts a caution, the status bar will display yellow.

1.6.4 Progress Bar

The progress bar displays the progress of an operation.

1.6.5 Program Memory

Program code can be loaded into the PICkit™ 2 Programming Software from File > 
Import HEX or it can be read from the device by clicking on the Read button. The origin 
of the code is displayed in the Source block. The Program Memory window displays 
the program code in hexadecimal. The code cannot be edited in the window.

The check box next to the Program Memory window controls whether the program 
memory will be programmed into the device or not. If the box is checked, the code 
displayed in the Program Memory window will be programmed into and used to verify 
the device. If the box is not checked, the program memory will not be programmed and 
it will not be used to verify the device.

1.6.6 Data EEPROM Memory

Similar to Program Memory above, program code can be loaded into the PICkit™ 2 
Programming Software from File > Import HEX or it can be read from the device by 
clicking on the Read button. The origin of the code is displayed in the Source block. 
The Data EEPROM Memory window displays the program code in hexadecimal. The 
code cannot be edited in the window.

The check box next to the Data EEPROM Memory window controls whether the data 
EEPROM memory will be programmed into the device or not. If the box is checked, the 
code displayed in the Data EEPROM Memory window will be programmed into and 
used to verify the device. If the box is not checked, the data EEPROM memory will not 
be programmed and it will not be used to verify the device.
DS51553A-page 10 © 2005 Microchip Technology Inc.
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Chapter 2.  Getting Started
2.1 INTRODUCTION

This chapter gives instruction on how to get started using the PICkit 2 Microcontroller 
Programmer to program Flash-based PICmicro® microcontroller units (MCU). 

For information on how to use the PICkit 2 Microcontroller Programmer with In-Circuit 
Serial Programming™ (ICSP™), refer to Chapter 3. “PICkit™ 2 and ICSP™”.

For information on how to update the PICkit 2 firmware operating system, refer to 
Chapter 4. “Updating the PICkit™ 2 Operating System”.

2.2 INSTALLING THE PICkit 2 PROGRAMMING SOFTWARE

Insert the PICkit™ 2 Starter Kit CD ROM into the CD ROM drive. In a few moments, 
the introductory screen should be displayed. Follow the directions on the screen for 
installing the PICkit™ 2 Programming Software.

If the introductory screen does not appear, browse to the CD ROM directory and select 
the AutorunPro.exe program.

2.3 USING THE PICkit 2 PROGRAMMING SOFTWARE

Start the PICkit™ 2 Programming Software by selecting Start > Programs > PICkit 2 
Microcontroller Programmer > PICkit 2. The programming interface appears as shown 
in Figure 2-1.

FIGURE 2-1: PICkit 2 PROGRAMMING SOFTWARE
© 2005 Microchip Technology Inc. DS51553A-page 11
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2.3.1 Selecting the Device Family

The PICkit 2 Microcontroller Programmer is capable of programming a variety of 
Flash-based Microchip PICmicro® microcontrollers.

The first step in using the PICkit 2 Microcontroller Programmer is to select the device 
family by clicking on the Device Family menu as shown in Figure 2-2.

FIGURE 2-2: SELECT DEVICE FAMILY

2.3.2 Device Identification

If the Mid-range (14-bit core) Flash device family is selected, the PICkit 2 
Microcontroller Programmer will automatically read the device ID word from PICmicro® 
MCU and display it in the Configuration window as shown in Figure 2-3.

FIGURE 2-3: IDENTIFY DEVICE

If the Baseline (12-bit core) Flash device family is selected, the user must select the 
specific device from the device drop down box as shown in Figure 2-4.

FIGURE 2-4: SELECT BASELINE FLASH DEVICE

CAUTION

Ensure that the correct Baseline Flash device has been selected. These devices do not 
contain a device ID to confirm device selection. Choosing the wrong Baseline Flash 
device may cause an erasing of the OSCCAL value stored in the last memory location.
DS51553A-page 12 © 2005 Microchip Technology Inc.
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2.3.3 Target Power

The PICkit 2 Microcontroller Programmer can supply power to the target. To enable 
power to the target device, check the Target Power check box as shown in Figure 2-5.

FIGURE 2-5: ENABLE TARGET POWER

2.3.4 Import HEX File

To import a compiled program (hex file), select File > Import HEX as shown in 
Figure 2-6. Browse for the hex file and click Open. The code is displayed in the 
Program Memory and EE Data Memory windows. The name of the hex file is displayed 
in the Source block.

FIGURE 2-6: IMPORT HEX FILE

Note: When starting the PICkit 2 Microcontroller Program, target power defaults 
to off.

CAUTION

The USB port current limit is set to 100 mA. If the target plus PICkit 2 Microcontroller 
Programmer exceed this current limit, the USB port will turn off. The target may be 
powered externally if more power is required.
© 2005 Microchip Technology Inc. DS51553A-page 13
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2.3.5 Write

After a device family has been selected and a hex file has been imported, the target 
PICmicro MCU can be programmed by clicking on the Write button. The PICmicro 
MCU will be erased and programmed with the hex code previously imported. The 
status of the Write operation is displayed in the status bar located under the Device 
Configuration window.

If the write is successful, the status bar turns green and displays “Write Successful”, as 
shown in Figure 2-7.

FIGURE 2-7: WRITE SUCCESSFUL STATUS

If the write fails, the status bar turns red and displays “Verify failed”, as shown in 
Figure 2-8. This error indicates that the data was corrupted during the programming 
sequence. If this error is displayed, try writing the program to the device again. If the 
error continues, see Chapter 5. “Troubleshooting” for assistance.

FIGURE 2-8: WRITE ERROR STATUS

Note: The device will be erased prior to programming. The PICkit 2 Microcontroller 
Programmer uses the bulk erase method that requires VDD voltage between 
4.5 to 5.5V
DS51553A-page 14 © 2005 Microchip Technology Inc.
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2.3.6 Automatic File Reload

Prior to each write, the imported hex file time stamp is compared to the version on the 
disk. If the version on the disk is newer, it is reloaded. This occurs only when a hex file 
has been read from the disk.

This feature ensures that the latest version built by MPLAB® IDE will be written to the 
device.

2.3.7 Verify

The Verify function verifies the device program to the imported hex file. It compares all 
areas of memory including program memory, data EEPROM memory, ID and configu-
ration bits.

To verify the code, import the hex file and click the Verify button. If the code is the 
same, the status bar turns green and displays “Device Verified”. If a discrepancy is 
found, the status bar turns red and displays where the error is located: “Error in 
Program Memory, Data EEPROM Memory, or Configuration Bits”.

2.3.8 Read

To view the code written to the PICmicro MCU, click the Read button. The code is 
displayed in the Program and Data EEPROM Memory windows for your review. If all 
zeros are displayed, it is possible that the device is code-protected.

2.3.9 Code-Protect Device

The Code-Protect Device function enables the code protection features of the 
PICmicro MCU. To protect the code, complete the following steps:

1. Import hex file.
2. Select Tools > Code Protect Device, as shown in Figure 2-9.
3. Click Write.

FIGURE 2-9: ENABLE CODE PROTECT

Note: If the device is read after it has been code-protected, Program Memory and 
Data EEPROM Memory windows will display all zeros.
© 2005 Microchip Technology Inc. DS51553A-page 15
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2.3.10 Erase

The Erase function erases the program memory, data EEPROM memory, ID and 
configuration bits. However, this function is not normally needed since the Write 
function performs an erase operation prior to programming the PICmicro MCU.

To erase the device, click the Erase button.

Note: The PICkit 2 Microcontroller Programmer uses the bulk erase method that 
requires VDD voltage between 4.5 to 5.5V.
DS51553A-page 16 © 2005 Microchip Technology Inc.
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Chapter 3.  PICkit™ 2 and ICSP™
3.1 INTRODUCTION

The PICkit™ 2 Microcontroller Programmer can program PICmicro® microcontrollers 
that are installed in an application circuit using In-Circuit Serial Programming™ 
(ICSP™). In-Circuit Serial Programming (ICSP) requires five signals:

• VPP – Programming Voltage; when applied, the device goes into Programming 
mode.

• ICSPCLK or PGC – Programming Clock; a unidirectional synchronous serial clock 
line from the programmer to the target.

• ICSPDAT or PGD – Programming Data; a bidirectional synchronous serial data line.
• VDD – Power Supply positive voltage.
• VSS – Power Supply ground reference.

However, the application circuit must be designed to allow all the programming signals 
to be connected to the PICmicro device without distorting the programming signals. 
Figure 3-1 shows a typical circuit as a starting point when designing an application 
circuit for ICSP. For successful ICSP programming, the precautions in the following 
sections need to be followed.

FIGURE 3-1: TYPICAL ICSP™ APPLICATION CIRCUIT

Note: For details on how a specific device is programmed, refer to the device 
programming specification available from the Microchip web site at 
www.microchip.com.
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3.2 ISOLATE VPP/MCLR/PORT PIN

When VPP voltage is applied, the application circuit needs to take into consideration 
that the typical VPP voltage is +12V. This may be an issue in the following situations:

3.2.1 If the VPP pin is used as a MCLR pin.

The application circuit typically is connected to a pull-up resistor/capacitor circuit, as 
recommended in the device data sheet. Care must be taken so that the VPP voltage 
slew rate is not slowed down and exceeds the rise time in the programming 
specification (typically 1 μs).

If a supervisory circuit or a push button is interfaced to the MCLR pin, it is 
recommended that they be isolated from the VPP voltage by using a Schottky-type 
diode or limiting resistor as shown in Figure 3-1. For more information about using 
supervisory circuits with ICSP, see Application Note AN820 “System Supervisors in 
ICSP™ Architectures” (DS00820).

3.2.2 If the VPP pin is used as an I/O port pin.

The application circuit that connects to the I/O pin may not be able to handle the +12V 
voltage. It is recommended to use a Schottky-type diode or limiting resistor as shown 
in Figure 3-1 to isolate the circuitry.

3.3 ISOLATE ICSPCLK OR PGC AND ICSPDAT OR PGD PINS

The ICSPCLK or PGC and ICSPDAT or PGD pins need to be isolated from the 
application circuit to prevent the programming signals from being affected by the 
application circuitry. ICSPCLK or PGC is a unidirection synchronous serial 
programming clock line from the programmer to the target. ICSPDAT or PGD is a 
bidirectional synchronous serial programming data line.

If the design permits, dedicate these pins for ICSP. However, if the application circuit 
requires that these pins be used in the application circuit, design the circuitry in a 
manner that does not alter the signal level and slew rates. Isolation circuitry will vary 
according to the application. Figure 3-1 shows one possibility by using series resistors 
to isolate the ICSP signals from the application circuit.
DS51553A-page 18 © 2005 Microchip Technology Inc.
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3.4 VDD

During ICSP programming, the PICmicro MCU needs to be powered in accordance 
with the device specification. Typically, the PICmicro MCU supply voltage is connected 
to the application circuit supply voltage. The application circuit can be powered by the 
PICkit 2 Microcontroller Programmer or externally. There are a few precautions that 
need to be observed.

3.4.1 The application circuit is powered by the PICkit 2 
Microcontroller Programmer.

The PICkit 2 Microcontroller Programmer supply voltage (VDD) is +5V. If the application 
circuit operates at a different voltage, isolation circuitry may be required so that the two 
voltage levels do not conflict.

3.4.2 The application circuit is powered externally.

The PICkit 2 Microcontroller Programmer supply voltage (VDD) is +5V. If the application 
circuit operates at a different voltage, isolation circuitry may be required so that the two 
voltage levels do not conflict.

3.4.3 Bulk Erase is used.

Some PICmicro MCU devices use a bulk erase function to erase program memory, 
data EEPROM memory, ID locations, and configuration bits. Typically, the bulk erase 
function requires a supply voltage (VDD) of 4.5 to 5.5 Volts (refer to the device 
programming specification for device specific requirements). 

This voltage range can be a problem if the application circuit is designed to operate at 
a different supply voltage range. In order to bulk erase the PICmicro MCU, the 
application circuit needs to take into consideration the bulk erase voltage requirement 
while protecting any voltage sensitive circuitry. 

CAUTION

The PICkit 2 Microcontroller Programmer supply voltage (VDD) is +5V.

CAUTION

The USB port current limit is set to 100 mA. If the target plus PICkit 2 Microcontroller 
Programmer exceeds this current limit, the USB port will turn off. The target may be 
powered externally if more power is required.

CAUTION

The PICkit 2 Microcontroller Programmer supply voltage (VDD) is +5V.
© 2005 Microchip Technology Inc. DS51553A-page 19
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3.5 VSS

The power supply ground reference, Vss, must be at the same potential as the 
application circuit.

3.6 OTHER CONSIDERATIONS

Minimize the distance the ICSP signals must travel by placing the ICSP connector as 
close to the application circuit PICmicro MCU as possible. Minimize any cable length 
between the PICkit 2 Microcontroller Programmer and application circuit PICmicro 
MCU. The goal is to keep the ICSP signals within the level and slew rate specifications 
for successful programming.
DS51553A-page 20 © 2005 Microchip Technology Inc.



PICkitTM 2 USER’S GUIDE
Chapter 4.  Updating the PICkit™ 2 Operating System
4.1 INTRODUCTION

This chapter describes how to update the PICkit™ 2 Microcontroller Programmer’s 
operating system.

4.2 UPDATING THE PICkit 2 MICROCONTROLLER PROGRAMMER

To update the PICkit 2 Microcontroller Programmer firmware Operating System, 
complete the following steps.

Step 1. Download the latest PICkit 2 Operating System from the Microchip web 
site at www.microchip.com.

Step 2. From the menu, select Tools > Download PICKit 2 Operating System as 
shown in Figure 4-1.

FIGURE 4-1: DOWNLOAD PICkit 2 OPERATING SYSTEM

Step 3. Browse to the directory where the latest Operating System code was 
saved as shown in Figure 4-2.

Step 4. Select the PK2*.hex file and click on the Open button.

FIGURE 4-2: SELECT PICkit 2 OPERATING SYSTEM

The progress of the OS update will be displayed in the status bar of the programming 
software and the Busy LED on the PICkit 2 Microcontroller Programmer will flash. 
When the update completes successfully, the status bar will display “Operating System 
Verified” and the Busy LED will go out. The operating system update is then complete.
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NOTES:
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Chapter 5.  Troubleshooting
5.1 INTRODUCTION

This chapter describes questions and answers to common problems associated with 
using the PICkit™ 2 Microcontroller Programmer and how to resolve them.

5.2 FREQUENTLY ASKED QUESTIONS

Device is not recognized

Question

Why am I receiving an “Insert Device” message?

Answer

Verify that the device is supported and that the target MCU is connected to the PICkit™ 2 
Microcontroller Programmer in accordance with Chapter 3. “PICkit™ 2 and ICSP™”.

Current Limit Exceeded

Question

Why am I receiving the error message “USB Hub Current Limit Exceeded” from the 
Microsoft® Windows® program?

Answer

Check for shorts on the circuit board.

Microsoft® Windows® Driver

Question

After plugging the PICkit™ 2 Microcontroller Programmer into the USB port, Windows® 
98 SE asks for a driver. Where is the driver?

Answer

PICkit™ 2 Microcontroller Programmer uses the drivers included with Windows®. 
When Windows® 98 SE prompts for a driver, select “Search for the best driver for your 
device.” Then select the check box next to “Microsoft Windows Update” and click Next. 
Windows will automatically install the appropriate driver. Do not use Microchip’s ICD 2 
USB driver.

Verify and Read Return all Zeros

Question

When the Verify or Read buttons are clicked, the Program Memory window comes up 
with all zeros. What is wrong?

Answer

The device may be code-protected. Ensure code protection has not been selected in 
the Configuration Word.
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Microsoft® Windows® 95/98/NT

Question

Can I run on Windows® 95/98/NT?

Answer

No. These operating systems either do not support USB or have drivers that are not 
compatible.
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Appendix 6. Hardware Schematics
6.1 INTRODUCTION

This appendix contains PICkit™ 2 Microcontroller Programmer schematic diagrams.

FIGURE 6-1: PICkit 2 SCHEMATIC DIAGRAM (PAGE 1 OF 2)
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FIGURE 6-2: PICkit 2 SCHEMATIC DIAGRAM (PAGE 2 OF 2)
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